Author Topic: Error in connectivity  (Read 781 times)

shabnam naderlou

  • Newbie
  • *
  • Posts: 4
    • View Profile
Error in connectivity
« on: September 21, 2018, 04:46:20 PM »
Dear All,
I am beginner to RASPA software. I am working on diffusion and storage of drugs within mofs.
At the starting kevel, I resieve an error and I dont solve it at all.
This is the error:
Error in CBMC growing scheme. No atoms  can be grown,  check the connectivity of your molecule
I checked all input files and those of them seems correct. How can I solve it?
Thanks for your time.
Best regards,

David Dubbeldam

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Error in connectivity
« Reply #1 on: September 21, 2018, 06:54:11 PM »
The most common reason is that your molecule contains a ring. RASPA can not handle flexible rings.

shabnam naderlou

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Error in connectivity
« Reply #2 on: September 21, 2018, 08:32:32 PM »
yes. I have a ring in my structure. but in molecule file, I define all of bonds as rigid. here is related molecule.def file.
# critical constants: Temperature [T], Pressure [Pa], and Acentric factor [-]
0.0
0.0
0.0
# Number Of Atoms
12
# Number of groups
1
# benzene-group
rigid
# number of atoms
12
# atomic positions
0  C_1      1.12695400   -0.52662000    0.00003600   
1  C_2      0.74022900    0.86804700   -0.00025100
2  N_9     -0.63270700    1.05031900    0.00004500
3  C_3     -1.60631600    0.07351800    0.00032400
4  N_8     -1.12034000   -1.20461800   -0.00001400
5  C_4      0.21606200   -1.50781300    0.00001800
6  F        2.44045100   -0.78310800    0.00001600
7  O_10     1.51472900    1.81170200    0.00003900
8  H_N9    -0.96541400    2.01129200   -0.00000100
9  O_11    -2.79825200    0.33618100   -0.00012900
10 H_N8    -1.80442000   -1.95287400   -0.00024000
11 H_xyl    0.48371800   -2.55620700   -0.00016000 

# Chiral centers Bond  Bend  UrayBradley InvBend  Torsion Imp. Torsion Bond/Bond Stretch/Bend Bend/Bend Bend/Torsion IntraVDW IntraCoulomb
               0   12     0            0       0        0            0         0            0         0            0        0            0
 Bond stretch: atom n1-n2, type, parameters
0 1   RIGID_BOND
1 2   RIGID_BOND
2 3   RIGID_BOND
3 4   RIGID_BOND
4 5   RIGID_BOND
5 0   RIGID_BOND
6 0   RIGID_BOND
7 1   RIGID_BOND
8 2   RIGID_BOND
9 3   RIGID_BOND
10 4  RIGID_BOND
11 0  RIGID_BOND
# Number of config moves
0

David Dubbeldam

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Error in connectivity
« Reply #3 on: September 22, 2018, 08:41:07 AM »
Remove the empty line after "11 H_xyl    0.48371800   -2.55620700   -0.00016000"

shabnam naderlou

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Error in connectivity
« Reply #4 on: September 22, 2018, 11:05:31 AM »
thanks for your reply.
I corrected this, but at this time, after 1 hour, running finished without any output or other folders :-[ :-[
here is my trial running simulation.input file:

SimulationType                   MonteCarlo
NumberOfCycles                   5000
NumberOfInitializationCycles     1000
RestartFile                      no
PrintEvery                       100

ChargeMethod                     Ewald
ChargeFromChargeEquilibration    yes
Forcefield                       local
CuttOffVDW                       13
EwaldPrecision                   1e-6

Framework 0
FrameworkName ZIF-8
UnitCells 2 2 2
ExternalTemperature 298.0
ExternalPressure 10000.0


ComputeNumberOfMoleculesHistogram yes
WriteNumberOfMoleculesHistogramEvery 100

Component 0 MoleculeName                   5-flouracil
            MoleculeDefinition             CastilloVlugtCalero2009
            IdealGasRosenbluthWeight       1.0
            TranslationProbability         1.0
            RotationProbability            1.0
            RegrowProbability              1.0
            ExtraFrameworkMolecule         no
            CreateNumberOfMolecules        0

in all of my runnings, I did not see any output file!
also, I did not see any error!

David Dubbeldam

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Error in connectivity
« Reply #5 on: September 23, 2018, 07:40:12 AM »
For our version of the code, this should not happen (on a standard unix system) and indicates something very strange on your system. Use a debugger to found out why it fails.
If you're using a version by other people (for example the numat github version) then it could be that their python additions might cause this problem.
« Last Edit: September 23, 2018, 07:43:27 AM by David Dubbeldam »

shabnam naderlou

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Error in connectivity
« Reply #6 on: September 26, 2018, 07:55:26 PM »
I tried to install your version with python setup.py install command. but when I run the program, I recieve this error:
OSError: /usr/local/lib/python2.7/dist-packages/RASPA2-2.0.3-py2.7-linux-x86_64.egg/RASPA2/simulations/lib/libraspa2.py: invalid ELF header

David Dubbeldam

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Error in connectivity
« Reply #7 on: September 29, 2018, 05:50:46 AM »
We do not have anything to do with python (that is an addition by 'numat' and their github version).
For our version (see the manual) you install with:
1 ) rm -rf autom4te.cache
2 ) mkdir m4
3 ) aclocal
4 ) autoreconf -i
5 ) automake --add-missing
6 ) autoconf
7 ) ./configure --prefix=${RASPA_DIR}
   or
   ./scripts/CompileScript/make-gcc-local
8 ) make
9 ) make install
« Last Edit: September 29, 2018, 03:26:15 PM by David Dubbeldam »