Author Topic: Problem in adsorption  (Read 270 times)

bluebox3486

  • Newbie
  • *
  • Posts: 1
    • View Profile
Problem in adsorption
« on: September 01, 2022, 01:59:58 PM »
Dear RASPA-Community,

I'm sorry my mother tongue is not english and I'm just undergraduate,so what i wrote might be weird.

I simulated N2 adsorption in AlPO-5 and compared to actual data,but data is quite different.

Actual data shows slight curve when pressure goes 1atm, but simulation data shows almost same.

I used parameters in RASPA example,so I think they were not problem.( I couldn't find LJ-Potentialfor P so I wrote random parameter & MOF data and simulated many times, data was similar :'( )

I think problem is my simulation.input is wrong and it does not successfully adsorbed N2. But I have no idea.

SimulationType                                              MonteCarlo
NumberOfCycles                                           4000
NumberOfInitializationCycles                        2000
PrintEvery                                                     200

Forcefield                                                      local       
RemoveAtomNumberCodeFromLabel          yes
UseChargesFromCIFFile                              yes

Framework                                                   0
FrameworkName                                         AlPO-5

UnitCells                                                      3 3 3
ExternalTemperature                                   77.35
ExternalPressure                                         70e3 75e3 80e3 85e3 90e3 95e3 100e3 105e3 110e3
FugacityCoefficient                                     1.0


Component 0 MoleculeName                    N2
            MoleculeDefinition                         local
            TranslationProbability                    0.5
            RotationProbability                        1.0
            ReinsertionProbability                  1.0
            SwapProbability                           1.0
            CreateNumberOfMolecules          0

I attached my graph for understanding.

thank you for the replying.




David Dubbeldam

  • Full Member
  • ***
  • Posts: 228
    • View Profile
Re: Problem in adsorption
« Reply #1 on: September 25, 2022, 05:42:33 PM »
I would suggest to talk to experimental people and ask why their data goes up.
I expect this is due to adsorption at the external surface. You would expect that the results for adsorption should level off to a saturation value.