SMF - Just Installed!

Main Menu

RASPA Simulations Directory not Found

Started by amogh, September 03, 2021, 07:05:04 PM

Previous topic - Next topic


Hey everyone,

I am new here and trying to conduct bulk density adsorption simulations with RASPA2. I am currently running through all of the setup and am trying to run one of the example simulations: examples/BookChapter/6-GrandCanonicalAdsorption/Methane/.

When examining the "run" file I see that it calls for a directory RASPA/simulations and then within simulations/lib and bin/simulate, however, I am unable to find any of these directories when downloading the RASPA2 repo from Github. I have also tried running ./run as a test to see if I missed these folders but it also states "No such file or directory". Any help would be greatly appreciated!


You first need to compile and install RASPA according to the procedure explained in the User Guide (section 1.3 Compiling and installing RASPA).
As part of this procedure, you will need to set the RASPA_DIR environment variable: export RASPA DIR=${HOME}/RASPA/simulations/
This is how you will create this directory which also contains the executable file.

Hope this helps.


Thank you for the direction! I realize I missed a step as mentioned in 1.3. However, when I try to "make install" or "sudo make install" on Mac OSX 10.15.7, it gives the error "gmkdir: cannot create directory '/lib': Read-only file system". I was wondering if there is something else I might have missed that causes this or if there are additional setup steps I need to take to set up RASPA on Mac OS. Thank you!


I was able to solve this issue and just thought I'd leave an update to this for anyone in the future that runs into this issue. On Mac OSX 10.15 and newer, the system must be put into Recovery mode by holding "command+R" while restarting. Once in Recovery mode, the Terminal must be accessed and the following commands should help resolve the issue:

csrutil status
csrutil disable

~boot up computer as normal again and reopen terminal~

sudo mount -uw /

~restart once more if the "sudo make install" command hits the same error while compiling~

Hope this helps!

David Dubbeldam

You should not install it on /lib, which is indeed a read-only systems directory.
Better just install it in your home account.

In the raspa-directory do:
rm -rf autom4te.cache 
mkdir m4 
autoreconf -i 
automake --add-missing 
make install


For setting the RASPA_DIR variable, what is the ideal path to do so? After cloning from Github and running the install commands in the RASPA2 main directory, I just want to make sure I set RASPA_DIR correctly as it often looks for files that don't exist when I have done it before.

David Dubbeldam

That is done in the run-file. See manual "1.3.5 Running RASPA".


I have figured out how to properly name the RASPA_DIR variable to my home directory and so my home directory structure looks like this:

amogh (home)
   -  RASPA2 (github repo)
   -  venv

Despite this, I tried running some of the sample simulations that come with the Github repo and hit a segfault when executing the run file. I used BookChapter/6-GrandCanonicalAdsorption/Methane example simulation which has all of the required files in its folder locally and modified the run file to this:

#! /bin/sh -f
export RASPA_DIR=$/RASPA/simulations
/Users/amogh/RASPA/simulations/bin/simulate -simulation.input

And this is the produced error when I try to run the "run" file from the home directory. I also tried to run this without the   
"-simulation.input" parameter and it claimed that it is unable to open the input file. All of the ".def" that are mentioned to not be found are in that local folder, which is visible in the RASPA2 repo as well.

(venv) (base) amogh@Amoghs-MBP ~ % ./RASPA_2/RASPA2/examples/BookChapter/6-GrandCanonicalAdsorption/Methane/run
'pseudo_atoms.def' file not found and therefore not used
'force_field_mixing_rules.def' file not found and therefore not used
'force_field.def' file not found and therefore not used

./RASPA_2/RASPA2/examples/BookChapter/6-GrandCanonicalAdsorption/Methane/run: line 5:  1436 Segmentation fault: 11  /Users/amogh/RASPA/simulations/bin/simulate -simulation.input

Any guidance would be greatly appreciated!